PriMoThemes — now s2Member® (official notice)

This is now a very OLD forum system. It's in READ-ONLY mode.
All community interaction now occurs at WP Sharks™. See: new forums @ WP Sharks™

New User Email Messages Not Sending

s2Member Plugin. A Membership plugin for WordPress®.

New User Email Messages Not Sending

Unread postby dskallman » September 10th, 2011, 6:08 pm

Hi,

I started using the Custom New User Registration Emails and they are not going out, no matter if it is the New User email or the Payment confirmation email. Have you seen this issue before? The user gets registered when using Pro Forms and then I redirect to payment, but no confirmations go out to the user. If I do forgot password then they can access, but how can I ensure the new user registration goes out?

Thanks!

Dana
User avatar
dskallman
Registered User
Registered User
 
Posts: 68
Joined: October 18, 2010

Re: New User Email Messages Not Sending

Unread postby dskallman » September 11th, 2011, 10:44 am

I just tested it putting the Email Configuration back to WordPress Defaults and the email gets sent with username and password. Any thoughts on why this may be?
User avatar
dskallman
Registered User
Registered User
 
Posts: 68
Joined: October 18, 2010

Re: New User Email Messages Not Sending

Unread postby Cristián Lávaque » September 14th, 2011, 2:11 am

What are the differences between the WP defaults and what you had with the problem?
Cristián Lávaque http://s2member.netIs s2Member working for you? Please . Thanks! :)
User avatar
Cristián Lávaque
Developer
Developer
 
Posts: 6836
Joined: December 22, 2010

Re: New User Email Messages Not Sending

Unread postby dskallman » September 14th, 2011, 7:15 am

It was a longer, personalized message that has more detail about the site and includes the username & password at the end of the message. Does that make a difference?
User avatar
dskallman
Registered User
Registered User
 
Posts: 68
Joined: October 18, 2010

Re: New User Email Messages Not Sending

Unread postby Cristián Lávaque » September 26th, 2011, 11:57 pm

Thanks. I emailed Jason about it, in case it's a bug.
Cristián Lávaque http://s2member.netIs s2Member working for you? Please . Thanks! :)
User avatar
Cristián Lávaque
Developer
Developer
 
Posts: 6836
Joined: December 22, 2010

Re: New User Email Messages Not Sending

Unread postby Jason Caldwell » September 27th, 2011, 8:03 pm

Hi Dana. A few tweaks later, please try this again in s2Member v110927+ and let me know your results. We found some issues related to BuddyPress v1.5 that were corrected, and some other minor tweaks took place as well. If you can test in the latest release please, that way we're on the same page here.
~ Jason Caldwell / Lead Developer
& Zeitgeist Movie Advocate: http://www.zeitgeistmovie.com/
Is the s2Member plugin working for you? Please rate s2Member at WordPress.org.
You'll need a ( comes in handy ). Then Image
.
User avatar
Jason Caldwell
Lead Developer
Lead Developer
 
Posts: 4045
Joined: May 3, 2010
Location: Georgia / USA

Re: New User Email Messages Not Sending

Unread postby dskallman » September 28th, 2011, 9:01 am

Hey Jason,

I just tested it and I had no email. I only got the administrator notice saying there is a new user, but not the custom email with the username and password. Any thoughts?

Thanks!

Dana
User avatar
dskallman
Registered User
Registered User
 
Posts: 68
Joined: October 18, 2010

Re: New User Email Messages Not Sending

Unread postby leoquijano » September 30th, 2011, 1:41 pm

Last edited by Cristián Lávaque on October 2nd, 2011, 1:40 am, edited 1 time in total.
Reason: Improve code readability. http://www.primothemes.com/forums/viewtopic.php?f=36&t=2780
User avatar
leoquijano
Registered User
Registered User
 
Posts: 7
Joined: September 30, 2011

Re: New User Email Messages Not Sending

Unread postby Jason Caldwell » October 3rd, 2011, 7:10 pm

Thanks for reporting this important issue.

I've been unable to reproduce this so far, but I see what you're describing. Can you please tell me what other plugins that you're running on this installation? Any other plugin that works to supplement the core function in some way?

is a valid recipient address, so I'd like to find the underlying cause as opposed to reducing the recipient down to just the email address.
~ Jason Caldwell / Lead Developer
& Zeitgeist Movie Advocate: http://www.zeitgeistmovie.com/
Is the s2Member plugin working for you? Please rate s2Member at WordPress.org.
You'll need a ( comes in handy ). Then Image
.
User avatar
Jason Caldwell
Lead Developer
Lead Developer
 
Posts: 4045
Joined: May 3, 2010
Location: Georgia / USA

Re: New User Email Messages Not Sending

Unread postby s_d_p » October 3rd, 2011, 9:53 pm

I had this problem with a smtp_mail plugin. It mostly just provides a menu to configure smpt mail settings, but perhaps it overrides some things. I also used mailpress, but removed it to test and the problem persisted.
User avatar
s_d_p
Registered User
Registered User
 
Posts: 23
Joined: July 26, 2011

Re: New User Email Messages Not Sending

Unread postby Jason Caldwell » October 3rd, 2011, 10:02 pm

Thank you. I'll test against that plugin.
Is this it? http://wordpress.org/extend/plugins/wp-mail-smtp/
~ Jason Caldwell / Lead Developer
& Zeitgeist Movie Advocate: http://www.zeitgeistmovie.com/
Is the s2Member plugin working for you? Please rate s2Member at WordPress.org.
You'll need a ( comes in handy ). Then Image
.
User avatar
Jason Caldwell
Lead Developer
Lead Developer
 
Posts: 4045
Joined: May 3, 2010
Location: Georgia / USA

Re: New User Email Messages Not Sending

Unread postby leoquijano » October 3rd, 2011, 10:11 pm

I'm also debugging. I narrowed it down to this MailEnable SMTP log entry:

RCPT TO:<My Name <my@email_address.com> 501 Invalid Address 52 21

I changed my name and my email, but notice that an additional, unclosed, "<" was added.
I'm now trying to figure out if it's a problem with my SMTP config, or if some plugin is interfering with the mail() call.
User avatar
leoquijano
Registered User
Registered User
 
Posts: 7
Joined: September 30, 2011

Re: New User Email Messages Not Sending

Unread postby leoquijano » October 3rd, 2011, 10:47 pm

Got it !!!

Ok, for the record, I'm using PHP 5.2.6 in a Windows box. This version of PHP has a known bug in the mail() implementation:

https://bugs.php.net/bug.php?id=28038

The bug was fixed in 5.2.11 and in 5.3.x branches.

Though actually, if you read the discussion there, they treat it as a workaround and not a bug fix. According to RFC2821, the RCPT TO field in an e-mail message must be e-mail only:
http://tools.ietf.org/html/rfc2821#section-6

The bug patch includes a patch for PHP that prevents the mail() call (which is used by PHPMailer, which in turn is used by Wordpress, which is used by s2Member) from enveloping the address with "<" and ">".

Anyone with a Windows box (pre-5.2.11) to confirm? Maybe a workaround is in order?

I think I can workaround it with the "wp_mail" filter, but this might bug other Windows users with older PHP versions (lower PHP 5.2 versions are still very common I think)
User avatar
leoquijano
Registered User
Registered User
 
Posts: 7
Joined: September 30, 2011

Re: New User Email Messages Not Sending

Unread postby leoquijano » October 3rd, 2011, 11:36 pm

User avatar
leoquijano
Registered User
Registered User
 
Posts: 7
Joined: September 30, 2011

Re: New User Email Messages Not Sending

Unread postby ryannagy » October 4th, 2011, 11:49 am

I am having a similar problem. I am manually adding several members. The members get added but I get an error message: "Internal Server Error.The server encountered an internal error or misconfiguration and was unable to complete your request."

At first the welcome emails were not sent. But then I deleted the plugin New User Email Setup By Alex Cragg in favor of S2Members built-in functionality. However, I am still getting the error message above. Though notification emails appear to be getting through.

Thoughts? I have got multiple affiliates sending out mass emails soon and would like to figure out what is going on ASAP. This is my first set-up using MediaTemple hosting. Perhaps I neglected to do something.
User avatar
ryannagy
Registered User
Registered User
 
Posts: 68
Joined: May 18, 2010

Re: New User Email Messages Not Sending

Unread postby Jason Caldwell » October 7th, 2011, 7:44 pm

~ Jason Caldwell / Lead Developer
& Zeitgeist Movie Advocate: http://www.zeitgeistmovie.com/
Is the s2Member plugin working for you? Please rate s2Member at WordPress.org.
You'll need a ( comes in handy ). Then Image
.
User avatar
Jason Caldwell
Lead Developer
Lead Developer
 
Posts: 4045
Joined: May 3, 2010
Location: Georgia / USA

Re: New User Email Messages Not Sending

Unread postby Jason Caldwell » October 7th, 2011, 7:52 pm

~ Jason Caldwell / Lead Developer
& Zeitgeist Movie Advocate: http://www.zeitgeistmovie.com/
Is the s2Member plugin working for you? Please rate s2Member at WordPress.org.
You'll need a ( comes in handy ). Then Image
.
User avatar
Jason Caldwell
Lead Developer
Lead Developer
 
Posts: 4045
Joined: May 3, 2010
Location: Georgia / USA

Re: New User Email Messages Not Sending

Unread postby leoquijano » October 7th, 2011, 7:53 pm

User avatar
leoquijano
Registered User
Registered User
 
Posts: 7
Joined: September 30, 2011

Re: New User Email Messages Not Sending

Unread postby Jason Caldwell » October 8th, 2011, 3:05 pm

Oh, very good then. Nice work and yes, thanks for the bug report on this.
~ Jason Caldwell / Lead Developer
& Zeitgeist Movie Advocate: http://www.zeitgeistmovie.com/
Is the s2Member plugin working for you? Please rate s2Member at WordPress.org.
You'll need a ( comes in handy ). Then Image
.
User avatar
Jason Caldwell
Lead Developer
Lead Developer
 
Posts: 4045
Joined: May 3, 2010
Location: Georgia / USA

Re: New User Email Messages Not Sending

Unread postby Jason Caldwell » October 9th, 2011, 7:27 pm

~ Jason Caldwell / Lead Developer
& Zeitgeist Movie Advocate: http://www.zeitgeistmovie.com/
Is the s2Member plugin working for you? Please rate s2Member at WordPress.org.
You'll need a ( comes in handy ). Then Image
.
User avatar
Jason Caldwell
Lead Developer
Lead Developer
 
Posts: 4045
Joined: May 3, 2010
Location: Georgia / USA

Re: New User Email Messages Not Sending

Unread postby Jason Caldwell » October 20th, 2011, 4:11 pm

s2Member v111017+ should completely resolve the issue reported here.
~ Thanks for the great feedback.
~ Jason Caldwell / Lead Developer
& Zeitgeist Movie Advocate: http://www.zeitgeistmovie.com/
Is the s2Member plugin working for you? Please rate s2Member at WordPress.org.
You'll need a ( comes in handy ). Then Image
.
User avatar
Jason Caldwell
Lead Developer
Lead Developer
 
Posts: 4045
Joined: May 3, 2010
Location: Georgia / USA

Re: New User Email Messages Not Sending

Unread postby leoquijano » October 21st, 2011, 1:22 am

Hi Jason,

Thanks for the update! I'm coming back to that project very soon, so I'll take a look from my side and verify everything's working good.
User avatar
leoquijano
Registered User
Registered User
 
Posts: 7
Joined: September 30, 2011

Re: New User Email Messages Not Sending

Unread postby leoquijano » October 21st, 2011, 12:13 pm

Allright: tested it without my workaround -> working fine! thanks!
User avatar
leoquijano
Registered User
Registered User
 
Posts: 7
Joined: September 30, 2011

Re: New User Email Messages Not Sending

Unread postby bertranddory » October 21st, 2011, 1:15 pm

I am running 111017, and I still have the same issue!

Can somebody help me here, as this is stopping my affiliate programme, and Click*Bank are looking to withdraw my product.

This is why I bought Pro, so I need some help here!

Thannkd
User avatar
bertranddory
Registered User
Registered User
 
Posts: 11
Joined: September 23, 2011

Re: New User Email Messages Not Sending

Unread postby Jason Caldwell » October 21st, 2011, 5:10 pm

For anyone else still having trouble with mail, please see this important post:
viewtopic.php?f=4&t=15555&p=48533#p48533

Also, please remember that emails will NOT be processed by s2Member if your Payment Gateway integration is incomplete in some way. It's always a good idea to enable s2Member's Logging/Debugging routines so you can see the communication that occurs behind-the-scene. s2Member's log files will tell you when, and to whom, email messages were sent to. For instance, with PayPal, check your Dashboard here:
s2Member -> PayPal Options -> Account Details -> Logging/Debugging
~ Jason Caldwell / Lead Developer
& Zeitgeist Movie Advocate: http://www.zeitgeistmovie.com/
Is the s2Member plugin working for you? Please rate s2Member at WordPress.org.
You'll need a ( comes in handy ). Then Image
.
User avatar
Jason Caldwell
Lead Developer
Lead Developer
 
Posts: 4045
Joined: May 3, 2010
Location: Georgia / USA

Next

Return to s2Member Plugin

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot] and 1 guest

cron