PriMoThemes — now s2Member® (official notice)

This is now a very OLD forum system. It's in READ-ONLY mode.
All community interaction now occurs at WP Sharks™. See: new forums @ WP Sharks™

Administrative: New User Notification not sending

s2Member Plugin. A Membership plugin for WordPress®.

Administrative: New User Notification not sending

Unread postby kvaughn » October 17th, 2011, 12:40 pm

I have the latest versin of s2Member running and for some reason the Administrative: New User Notification email is not being sent. Not sure where to start troubleshooting this, can someone please help? Thanks in advance for your assistance...
User avatar
kvaughn
Registered User
Registered User
 
Posts: 31
Joined: August 26, 2011

Re: Administrative: New User Notification not sending

Unread postby Eduan » October 17th, 2011, 1:06 pm

Did you configure the email settings correctly?
If you're using PayPal go to WP Admin -> s2Member -> PayPal® Options and configure everything there.

Hope this helps. :)
Now officially accepting Professional s2Member installations along with (a.k.a. Ace).
If you're interested in a Professional s2Member Installation, or a Custom Coding Job, you can send your request .
User avatar
Eduan
Experienced User
Experienced User
 
Posts: 1154
Joined: August 27, 2011
Location: Taxco de Alarcón, Guerrero, México.

Re: Administrative: New User Notification not sending

Unread postby kvaughn » October 17th, 2011, 1:17 pm

Thanks for the quick reply Eduan. I'm not using PayPal but I think I have configured email correctly. I have entered everything into General Options > Email Configuration which seems to be pretty straight forward. I have used s2Member on previous sites and have had no issues.
User avatar
kvaughn
Registered User
Registered User
 
Posts: 31
Joined: August 26, 2011

Re: Administrative: New User Notification not sending

Unread postby Eduan » October 17th, 2011, 1:33 pm

Have you got the Pro version? If so what do you use to receive payments (ccBill, ClickBank etc.)?
Now officially accepting Professional s2Member installations along with (a.k.a. Ace).
If you're interested in a Professional s2Member Installation, or a Custom Coding Job, you can send your request .
User avatar
Eduan
Experienced User
Experienced User
 
Posts: 1154
Joined: August 27, 2011
Location: Taxco de Alarcón, Guerrero, México.

Re: Administrative: New User Notification not sending

Unread postby kvaughn » October 17th, 2011, 1:47 pm

No, I am not running the pro version. There is no charge for the site, it's for a group of top Neurosurgeons and their patient discussions.
User avatar
kvaughn
Registered User
Registered User
 
Posts: 31
Joined: August 26, 2011

Re: Administrative: New User Notification not sending

Unread postby Eduan » October 17th, 2011, 1:49 pm

Oh so it's free?
Now officially accepting Professional s2Member installations along with (a.k.a. Ace).
If you're interested in a Professional s2Member Installation, or a Custom Coding Job, you can send your request .
User avatar
Eduan
Experienced User
Experienced User
 
Posts: 1154
Joined: August 27, 2011
Location: Taxco de Alarcón, Guerrero, México.

Re: Administrative: New User Notification not sending

Unread postby kvaughn » October 17th, 2011, 1:51 pm

Yes. No charge. Free to use the sute for this group of surgeons.
User avatar
kvaughn
Registered User
Registered User
 
Posts: 31
Joined: August 26, 2011

Re: Administrative: New User Notification not sending

Unread postby Eduan » October 17th, 2011, 1:56 pm

Okay, have you selected under WP Admin -> s2Member -> General Options -> Email Configuration -> New User Email Configuration that it does send the email?
Now officially accepting Professional s2Member installations along with (a.k.a. Ace).
If you're interested in a Professional s2Member Installation, or a Custom Coding Job, you can send your request .
User avatar
Eduan
Experienced User
Experienced User
 
Posts: 1154
Joined: August 27, 2011
Location: Taxco de Alarcón, Guerrero, México.

Re: Administrative: New User Notification not sending

Unread postby kvaughn » October 17th, 2011, 2:03 pm

Thanks... yes, the New User email does work. The new user does get their email notification with username and password but the admin does not (Administrative: New User Notification ).
User avatar
kvaughn
Registered User
Registered User
 
Posts: 31
Joined: August 26, 2011

Re: Administrative: New User Notification not sending

Unread postby Eduan » October 17th, 2011, 2:12 pm

Now officially accepting Professional s2Member installations along with (a.k.a. Ace).
If you're interested in a Professional s2Member Installation, or a Custom Coding Job, you can send your request .
User avatar
Eduan
Experienced User
Experienced User
 
Posts: 1154
Joined: August 27, 2011
Location: Taxco de Alarcón, Guerrero, México.

Re: Administrative: New User Notification not sending

Unread postby Eduan » October 17th, 2011, 3:18 pm

Please tell me if it works.
Now officially accepting Professional s2Member installations along with (a.k.a. Ace).
If you're interested in a Professional s2Member Installation, or a Custom Coding Job, you can send your request .
User avatar
Eduan
Experienced User
Experienced User
 
Posts: 1154
Joined: August 27, 2011
Location: Taxco de Alarcón, Guerrero, México.

Re: Administrative: New User Notification not sending

Unread postby kvaughn » October 17th, 2011, 3:41 pm

I have a similar issue to that thread but actually the opposit... the user registration confirmation message does not send but the admin reg alert message does. I have tested the wp_mail() function and it does work. I placed the following code into a page, <?php wp_mail( "info@rrnmf.com", "wp mail test", "this is a test" ); ?>, and it sends mail fine.
User avatar
kvaughn
Registered User
Registered User
 
Posts: 31
Joined: August 26, 2011

Re: Administrative: New User Notification not sending

Unread postby kvaughn » October 17th, 2011, 5:00 pm

Just upgraded to s2Member Pro hoping that would help. It did not... Any assistance with this would be greatty appreciated!
User avatar
kvaughn
Registered User
Registered User
 
Posts: 31
Joined: August 26, 2011

Re: Administrative: New User Notification not sending

Unread postby Jason Caldwell » October 17th, 2011, 7:17 pm

Thanks for reporting this important issue.

Please test again with s2Member v111017+, released today.
Changelog here ( there were some additional tweaks for edge cases that may help you )
http://wordpress.org/extend/plugins/s2member/changelog/

If the latest release does not help, please let me know.
~ Jason Caldwell / Lead Developer
& Zeitgeist Movie Advocate: http://www.zeitgeistmovie.com/
Is the s2Member plugin working for you? Please rate s2Member at WordPress.org.
You'll need a ( comes in handy ). Then Image
.
User avatar
Jason Caldwell
Lead Developer
Lead Developer
 
Posts: 4045
Joined: May 3, 2010
Location: Georgia / USA

Re: Administrative: New User Notification not sending

Unread postby kvaughn » October 18th, 2011, 11:12 am

Thanks Jason... I updated s2Member to v111017+ this morning and then tested. Unfortunately the admin new user notification is still not sending.
User avatar
kvaughn
Registered User
Registered User
 
Posts: 31
Joined: August 26, 2011

Re: Administrative: New User Notification not sending

Unread postby Eduan » October 18th, 2011, 5:17 pm

Have you tried something/anything that's in WP Admin -> s2Member -> API / Notifications?
Now officially accepting Professional s2Member installations along with (a.k.a. Ace).
If you're interested in a Professional s2Member Installation, or a Custom Coding Job, you can send your request .
User avatar
Eduan
Experienced User
Experienced User
 
Posts: 1154
Joined: August 27, 2011
Location: Taxco de Alarcón, Guerrero, México.

Re: Administrative: New User Notification not sending

Unread postby kvaughn » October 19th, 2011, 11:04 am

Hmm, I believe this is to add notification urls if you use affiliate software, which we don't at this point.
User avatar
kvaughn
Registered User
Registered User
 
Posts: 31
Joined: August 26, 2011

Re: Administrative: New User Notification not sending

Unread postby kvaughn » October 19th, 2011, 1:48 pm

Any help with this would be greatly appreciated. This is a critical feature for the success of the site...
User avatar
kvaughn
Registered User
Registered User
 
Posts: 31
Joined: August 26, 2011

Re: Administrative: New User Notification not sending

Unread postby Jason Caldwell » October 20th, 2011, 3:08 pm

Attachments
SNAG-0041.png
~ Jason Caldwell / Lead Developer
& Zeitgeist Movie Advocate: http://www.zeitgeistmovie.com/
Is the s2Member plugin working for you? Please rate s2Member at WordPress.org.
You'll need a ( comes in handy ). Then Image
.
User avatar
Jason Caldwell
Lead Developer
Lead Developer
 
Posts: 4045
Joined: May 3, 2010
Location: Georgia / USA

Re: Administrative: New User Notification not sending

Unread postby kvaughn » October 20th, 2011, 5:13 pm

User avatar
kvaughn
Registered User
Registered User
 
Posts: 31
Joined: August 26, 2011

Re: Administrative: New User Notification not sending

Unread postby kvaughn » October 20th, 2011, 5:19 pm

User avatar
kvaughn
Registered User
Registered User
 
Posts: 31
Joined: August 26, 2011

Re: Administrative: New User Notification not sending

Unread postby Jason Caldwell » October 20th, 2011, 6:12 pm

Thank you. I'm not finding anything in these plugins that would conflict with this functionality. And unfortunately, I've been unable to reproduce this far. If you would like to provide me with a Dashboard login and FTP access, I'll be happy to run diagnostics on your installation and provide a solution.

If possible, please submit this form with those details for me:
http://www.s2member.com/contact/
~ Jason Caldwell / Lead Developer
& Zeitgeist Movie Advocate: http://www.zeitgeistmovie.com/
Is the s2Member plugin working for you? Please rate s2Member at WordPress.org.
You'll need a ( comes in handy ). Then Image
.
User avatar
Jason Caldwell
Lead Developer
Lead Developer
 
Posts: 4045
Joined: May 3, 2010
Location: Georgia / USA

Re: Administrative: New User Notification not sending

Unread postby Jason Caldwell » October 20th, 2011, 6:31 pm

~ Jason Caldwell / Lead Developer
& Zeitgeist Movie Advocate: http://www.zeitgeistmovie.com/
Is the s2Member plugin working for you? Please rate s2Member at WordPress.org.
You'll need a ( comes in handy ). Then Image
.
User avatar
Jason Caldwell
Lead Developer
Lead Developer
 
Posts: 4045
Joined: May 3, 2010
Location: Georgia / USA

Re: Administrative: New User Notification not sending

Unread postby bertranddory » October 21st, 2011, 11:24 am

Hi,

It seems I am running in the same issue. I have the latest versions of s2members and Pro. Any help would be appreciated!
Thanks
User avatar
bertranddory
Registered User
Registered User
 
Posts: 11
Joined: September 23, 2011

Re: Administrative: New User Notification not sending

Unread postby Jason Caldwell » October 21st, 2011, 5:04 pm

~ Jason Caldwell / Lead Developer
& Zeitgeist Movie Advocate: http://www.zeitgeistmovie.com/
Is the s2Member plugin working for you? Please rate s2Member at WordPress.org.
You'll need a ( comes in handy ). Then Image
.
User avatar
Jason Caldwell
Lead Developer
Lead Developer
 
Posts: 4045
Joined: May 3, 2010
Location: Georgia / USA

Next

Return to s2Member Plugin

Who is online

Users browsing this forum: Bing [Bot], Exabot [Bot], Yahoo [Bot] and 1 guest