PriMoThemes — now s2Member® (official notice)

This is now a very OLD forum system. It's in READ-ONLY mode.
All community interaction now occurs at WP Sharks™. See: new forums @ WP Sharks™

Quick Cache Serving Pages through HTTPS at random

Quick Cache Plugin. Speeds up WordPress®.

Quick Cache Serving Pages through HTTPS at random

Postby oppodeldoc » February 4th, 2012, 5:22 pm

Hey there, thanks in advance for any help you can offer.

First off, I love this plugin because of its simplicity, and I've recommended it for use on several websites for clients because they can use it without getting scared. Thanks to the developer(s) for all the work they've done.

At first, I thought this problem was an issue with a single website I was using, but I'm seeing it on two sites now that both use Quick Cache so I'm trying to isolate what the problem could be.

Both sites have a lot of posts and pages, one site is a very high-traffic blog, the other has many pages and posts. When I'm not logged in and clicking around the site (admiring the quick page loads) occasionally, I'll run into a page that loads completely unformatted, as if the style sheet is not loading. When looking at the page source, it turns out that the links to all the site assets have https:// prepended to them instead of the http protocol. Since there is no SSL installed on the server, the assets throw a 404 error and the pages load unstyled. Hitting the clear cache button after logging in fixes this problem, but then I'll find another page or post that has this same problem later on. In one case the home page had the problem, which obviously was a big problem, so I've had to disable the plugin on the production site. The site itself is here, but I can't turn the caching plugin back on until we get this resolved so I don't know if the site will be able to show what's going on:

I didn't build this site, just did some upgrades and template changes over the past 6 months, but I've got it on pretty good authority that they NEVER had ssl installed on their servers, so the https protocol was never used before I came on. Not sure why it's showing up now.

I've isolated Quick Cache as the problem, as I've disabled all other plugins, checked server logs, and it doesn't happen at all when the cache is turned off and/or I'm logged in, but happens after repeatedly re-installing, upgrading or clearing the cache.

Both servers are running PHP 5.2 and one server was running Wordpress 3.2 until yesterday. The problem happened on 3.2 and continues with the latest versions of Wordpress AND Quick Cache. Any information or ideas will be appreciated. I'd really hate to try to find a different caching plugin or go back to Super Cache, but I can't use this in production if it keeps happening. Thanks again! -Matt
User avatar
Registered User
Registered User
Posts: 1
Joined: February 4, 2012

Return to Quick Cache Plugin

Who is online

Users browsing this forum: No registered users and 2 guests